Bump nessai version for Python 3.6 support

9 jobs for add-nessai-sampler in 16 minutes and 10 seconds (queued for 2 seconds)
Status Job ID Name Coverage
  Test
passed #1219471
authors

00:01:00

passed #1219464
basic-3.7

00:01:03

passed #1219470
containers

00:01:09

passed #1219472
precommits-py3.7

00:01:28

failed #1219467
python-3.6

00:05:06

failed #1219469
python-3.6-samplers

00:16:09

failed #1219465
python-3.7

00:01:11

failed #1219468
python-3.7-samplers

00:01:22

failed #1219466
python-3.8

00:01:21

 
Name Stage Failure
failed
python-3.6-samplers Test
    nargs = len(inspect.getargspec(LogLikelihood).args) - inspect.ismethod(LogLikelihood)

-- Docs: https://docs.pytest.org/en/stable/warnings.html
=========================== short test summary info ============================
FAILED test/integration/sampler_run_test.py::TestRunningSamplers::test_run_nessai
FAILED test/integration/sampler_run_test.py::TestRunningSamplers::test_run_pymc3
============ 2 failed, 12 passed, 75 warnings in 894.52s (0:14:54) =============
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
python-3.6 Test
    snr[x] = interferometer.matched_filter_snr(signal=muf)

-- Docs: https://docs.pytest.org/en/stable/warnings.html
=========================== short test summary info ============================
FAILED test/core/sampler/pymc3_test.py::TestPyMC3::test_default_kwargs - Attr...
FAILED test/core/sampler/pymc3_test.py::TestPyMC3::test_translate_kwargs - At...
=========== 2 failed, 843 passed, 208 warnings in 233.84s (0:03:53) ============
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
python-3.7-samplers Test
  File "/opt/conda/envs/python37/lib/python3.7/site-packages/ligo/skymap/_astropy_init.py", line 23, in <module>
from astropy.tests.runner import TestRunner
File "/opt/conda/envs/python37/lib/python3.7/site-packages/astropy/__init__.py", line 92, in <module>
_check_requirement('erfa', __minimum_erfa_version__)
File "/opt/conda/envs/python37/lib/python3.7/site-packages/astropy/__init__.py", line 86, in _check_requirement
raise ImportError(msg)
ImportError: erfa version 1.7 or later must be installed to use Astropy. erfa is not installed.
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
python-3.8 Test
  File "/opt/conda/envs/python38/lib/python3.8/site-packages/ligo/skymap/_astropy_init.py", line 23, in <module>
from astropy.tests.runner import TestRunner
File "/opt/conda/envs/python38/lib/python3.8/site-packages/astropy/__init__.py", line 92, in <module>
_check_requirement('erfa', __minimum_erfa_version__)
File "/opt/conda/envs/python38/lib/python3.8/site-packages/astropy/__init__.py", line 86, in _check_requirement
raise ImportError(msg)
ImportError: erfa version 1.7 or later must be installed to use Astropy. erfa is not installed.
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
python-3.7 Test
  File "/opt/conda/envs/python37/lib/python3.7/site-packages/ligo/skymap/_astropy_init.py", line 23, in <module>
from astropy.tests.runner import TestRunner
File "/opt/conda/envs/python37/lib/python3.7/site-packages/astropy/__init__.py", line 92, in <module>
_check_requirement('erfa', __minimum_erfa_version__)
File "/opt/conda/envs/python37/lib/python3.7/site-packages/astropy/__init__.py", line 86, in _check_requirement
raise ImportError(msg)
ImportError: erfa version 1.7 or later must be installed to use Astropy. erfa is not installed.
Cleaning up file based variables
ERROR: Job failed: exit code 1