lalinference: remove configure checks for metaio

this package doensn't explicitly needa metaio, so we don't need to link against it
parent 62d6162b
......@@ -52,7 +52,6 @@ requirements:
- lalpulsar >={{ lalpulsar_version }}
- libcblas=*=*netlib
- llvm-openmp # [osx]
- metaio
- openmp # [linux]
- openmpi
run:
......@@ -68,7 +67,6 @@ requirements:
- lalpulsar >={{ lalpulsar_version }}
- libcblas
- llvm-openmp # [osx]
- metaio
- openmp # [linux]
- openmpi
# hdf5 links against zlib so we need to reference it
......@@ -125,7 +123,6 @@ outputs:
- libcblas
- lscsoft-glue >=1.54.1
- matplotlib >=1.2.0
- metaio
- {{ pin_compatible('numpy') }}
- python
- python-lal >={{ lal_version }}
......
......@@ -187,14 +187,6 @@ LALSUITE_ENABLE_FAST_GSL
# check for gsl headers
AC_CHECK_HEADERS([gsl/gsl_errno.h],,[AC_MSG_ERROR([could not find the gsl/gsl_errno.h header])])
# metaio
PKG_CHECK_MODULES([METAIO],[libmetaio],[true],[false])
LALSUITE_ADD_FLAGS([C],[${METAIO_CFLAGS}],[${METAIO_LIBS}])
AC_CHECK_LIB([metaio],[MetaioOpen],,[AC_MSG_ERROR([could not find the metaio library])])
# check for libmetaio headers
AC_CHECK_HEADERS([metaio.h],,[AC_MSG_ERROR([could not find the metaio.h header])])
# check for hdf5 support
HDF5_ENABLE_VAL="DISABLED"
# Note that AX_LIB_HDF5 uses h5cc to determine compiler for configure tests.
......
......@@ -9,7 +9,6 @@ Build-Depends: debhelper (>= 9),
libchealpix-dev (>= 3.30.0),
libgsl-dev | libgsl0-dev (>= 1.15),
libhdf5-dev,
libmetaio-dev (>= 8.2),
liboctave-dev,
libopenmpi-dev,
pkg-config (>= 0.18.0),
......@@ -57,7 +56,6 @@ Package: lalinference
Architecture: any
Depends: ${misc:Depends},
${shlibs:Depends},
libmetaio1 (>= 8.2),
openmpi-bin,
openssh-client,
lal (>= @MIN_LAL_VERSION@~),
......@@ -82,7 +80,6 @@ Depends: ${misc:Depends},
libchealpix-dev (>= 3.30.0),
libgsl-dev | libgsl0-dev (>= 1.15),
libhdf5-dev,
libmetaio-dev (>= 8.2),
python-healpy (>= 1.9.1),
zlib1g-dev,
lal-dev (>= @MIN_LAL_VERSION@~),
......
......@@ -12,6 +12,6 @@ LALINFERENCE_PYTHON_PATH=@pyexecdir@
Name: LALInference
Description: LAL Inference Library Support
Version: @VERSION@
Requires.private: gsl, lal >= @LAL_VERSION@, libmetaio, lalmetaio >= @LALMETAIO_VERSION@, lalinspiral >= @LALINSPIRAL_VERSION@, lalpulsar >= @LALPULSAR_VERSION@
Requires.private: gsl, lal >= @LAL_VERSION@, lalmetaio >= @LALMETAIO_VERSION@, lalinspiral >= @LALINSPIRAL_VERSION@, lalpulsar >= @LALPULSAR_VERSION@
Libs: -L${libdir} -llalinference
Cflags: -I${includedir} @OPENMP_CFLAGS@
......@@ -33,7 +33,6 @@ BuildRequires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
BuildRequires: lalburst-devel >= @MIN_LALBURST_VERSION@
BuildRequires: lalinspiral-devel >= @MIN_LALINSPIRAL_VERSION@
BuildRequires: lalpulsar-devel >= @MIN_LALPULSAR_VERSION@
BuildRequires: libmetaio-devel
BuildRequires: openmpi-devel
BuildRequires: pkgconfig >= 0.18.0
......@@ -102,7 +101,6 @@ BuildRequires: lalpulsar-octave >= @MIN_LALPULSAR_VERSION@
Requires: chealpix
Requires: gsl >= 1.15
Requires: hdf5
Requires: libmetaio
Requires: openmpi
Requires: openssh-clients
Requires: lal >= @MIN_LAL_VERSION@
......@@ -124,7 +122,6 @@ Group: LAL
Requires: %{name} = %{version}
Requires: chealpix-devel >= 3.30.0
Requires: gsl-devel >= 1.15
Requires: libmetaio-devel
Requires: lal-devel >= @MIN_LAL_VERSION@
Requires: lalmetaio-devel >= @MIN_LALMETAIO_VERSION@
Requires: lalsimulation-devel >= @MIN_LALSIMULATION_VERSION@
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment