Commit ef1e0100 authored by Sophie Hourihane's avatar Sophie Hourihane
Browse files

Fixing pip install -> setup.py install and getting rid of deprecated...

Fixing pip install -> setup.py install and getting rid of deprecated BAYESWAVE_UTILS environment variable
parent 0dadee60
Pipeline #476938 passed with stages
in 1 minute and 45 seconds
......@@ -13,7 +13,7 @@ pyminor=$(python -c 'import sys; print(sys.version_info[1])')
# BayesWave
# TODO we should deprecate this and enforce that everyone installing from source
# installs in an actual environment when they do so, then we will never need to update paths like this
export PATH=$BAYESWAVE_UTILS_PREFIX/bin:${BAYESWAVE_UTILS_PREFIX}:${BAYESWAVE_PREFIX}/bin:${PATH}
export PATH=${BAYESWAVE_PREFIX}/bin:${PATH}
export LD_LIBRARY_PATH=${BAYESWAVE_PREFIX}/lib:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=${BAYESWAVE_PREFIX}/lib64:${LD_LIBRARY_PATH}
export PYTHONPATH=${BAYESWAVE_PREFIX}/lib/python${pymajor}.${pyminor}/site-packages:${PYTHONPATH}
......
......@@ -44,7 +44,7 @@ echo "Installing to ${install_dir}"
# Install python codes
#
pushd BayesWaveUtils
python -m pip install --upgrade .
python setup.py install --prefix ${install_dir} --force
popd
#
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment