Commit 198cb7b2 authored by Tanner Prestegard's avatar Tanner Prestegard

updating version numbers and changelog for packaging

parent b47655ef
ligo-gracedb (1.24-1) unstable; urgency=low
* Added a check on .netrc file permissions
* Added capability to create events with labels attached
* Added offline boolean parameter when creating events
-- Tanner Prestegard <tanner.prestegard@ligo.org> Thu, 25 May 2017 11:42:24 -0500
ligo-gracedb (1.23-1) unstable; urgency=low ligo-gracedb (1.23-1) unstable; urgency=low
* Improved exception handling and display of tracebacks in REST client * Improved exception handling and display of tracebacks in REST client
......
%define name ligo-gracedb %define name ligo-gracedb
%define version 1.23 %define version 1.24
%define unmangled_version 1.23 %define unmangled_version 1.24
%define release 1 %define release 1
Summary: Gravity Wave Candidate Event Database Summary: Gravity Wave Candidate Event Database
......
...@@ -18,7 +18,7 @@ ...@@ -18,7 +18,7 @@
__all__ = ["cli", "rest"] __all__ = ["cli", "rest"]
GIT_TAG = 'gracedb-1.23-1' GIT_TAG = 'gracedb-1.24-1'
# issue 717. Required for backward compatibility -- make sure "from ligo import gracedb" # issue 717. Required for backward compatibility -- make sure "from ligo import gracedb"
# works as it used to. # works as it used to.
......
...@@ -27,7 +27,7 @@ DEFAULT_SERVICE_URL = "https://gracedb.ligo.org/gracedb/api" ...@@ -27,7 +27,7 @@ DEFAULT_SERVICE_URL = "https://gracedb.ligo.org/gracedb/api"
DEFAULT_BASIC_URL = "https://gracedb.ligo.org/apibasic/" DEFAULT_BASIC_URL = "https://gracedb.ligo.org/apibasic/"
GIT_TAG = 'gracedb-1.23-1' GIT_TAG = 'gracedb-1.24-1'
DEFAULT_COLUMNS = "graceid,labels,group,pipeline,search,far,gpstime,created,dataurl" DEFAULT_COLUMNS = "graceid,labels,group,pipeline,search,far,gpstime,created,dataurl"
......
...@@ -367,7 +367,7 @@ class TestGracedb(unittest.TestCase): ...@@ -367,7 +367,7 @@ class TestGracedb(unittest.TestCase):
def test_gittag(self): def test_gittag(self):
# try to make sure GIT_TAG is set properly. # try to make sure GIT_TAG is set properly.
import errno import errno
version = "1.23" version = "1.24"
try: try:
# If we are in the source dir (setup.py is available) # If we are in the source dir (setup.py is available)
# make sure the version above agrees. # make sure the version above agrees.
......
...@@ -20,7 +20,7 @@ import os ...@@ -20,7 +20,7 @@ import os
from setuptools import setup from setuptools import setup
version = "1.23" version = "1.24"
setup( setup(
name = "ligo-gracedb", name = "ligo-gracedb",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment