Commit 29529bf9 authored by Branson Stephens's avatar Branson Stephens

Switch to using ligo as a namespace package.

parent aeb04413
__import__('pkg_resources').declare_namespace(__name__)
__all__ = ["cli", "rest"]
GIT_TAG = 'gracedb-1.18.dev0-1'
GIT_TAG = 'gracedb-1.18.dev1-1'
# issue 717. Required for backward compatibility -- make sure "from ligo import gracedb"
# works as it used to.
......
......@@ -23,7 +23,7 @@ from ligo.gracedb.rest import GraceDb
DEFAULT_SERVICE_URL = "https://gracedb.ligo.org/gracedb/api"
GIT_TAG = 'gracedb-1.18.dev0-1'
GIT_TAG = 'gracedb-1.18.dev1-1'
DEFAULT_COLUMNS = "graceid,labels,group,pipeline,search,far,gpstime,created,dataurl"
......
......@@ -280,7 +280,7 @@ class TestGracedb(unittest.TestCase):
def test_gittag(self):
# try to make sure GIT_TAG is set properly.
import errno
version = "1.18.dev0"
version = "1.18.dev1"
try:
# If we are in the source dir (setup.py is available)
# make sure the version above agrees.
......
......@@ -3,7 +3,7 @@ import os
from distutils.core import setup
version = "1.18.dev0"
version = "1.18.dev1"
setup(
name = "ligo-gracedb",
......@@ -16,10 +16,11 @@ setup(
url = "http://www.lsc-group.phys.uwm.edu/daswg/gracedb.html",
license = 'GPL',
provides = ['ligo.gracedb'],
packages = [ 'ligo', 'ligo.gracedb', 'ligo.gracedb.test'],
packages = [ 'ligo.gracedb', 'ligo.gracedb.test'],
namespace_packages = ['ligo'],
package_data = { 'ligo.gracedb.test' : ['data/*', 'test.sh', 'README'] },
requires = ['ligo', 'M2Crypto'],
requires = ['M2Crypto'],
scripts = [
os.path.join('bin','gracedb'),
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment