Commit 3e9b1e84 authored by Branson Stephens's avatar Branson Stephens

Packaging changes for v1.18

parent 29529bf9
ligo-gracedb (1.18-1) unstable; urgency=low
* Added comment to EM Observation record
* Allow python lists as arguments to writeEMObservation
* Changed ligo to namespace package
-- Branson Stephens <branson.stephens@ligo.org> Wed, 13 May 2015 14:00:00 -0500
ligo-gracedb (1.18.dev0-1) unstable; urgency=low ligo-gracedb (1.18.dev0-1) unstable; urgency=low
* New features for robotic basic auth * New features for robotic basic auth
* New features for EM observation records * New features for EM observation records
......
%define name ligo-gracedb %define name ligo-gracedb
%define version 1.17 %define version 1.18
%define unmangled_version 1.17 %define unmangled_version 1.18
%define release 1 %define release 1
Summary: Gravity Wave Candidate Event Database Summary: Gravity Wave Candidate Event Database
......
__all__ = ["cli", "rest"] __all__ = ["cli", "rest"]
GIT_TAG = 'gracedb-1.18.dev1-1' GIT_TAG = 'gracedb-1.18-1'
# issue 717. Required for backward compatibility -- make sure "from ligo import gracedb" # issue 717. Required for backward compatibility -- make sure "from ligo import gracedb"
# works as it used to. # works as it used to.
......
...@@ -23,7 +23,7 @@ from ligo.gracedb.rest import GraceDb ...@@ -23,7 +23,7 @@ from ligo.gracedb.rest import GraceDb
DEFAULT_SERVICE_URL = "https://gracedb.ligo.org/gracedb/api" DEFAULT_SERVICE_URL = "https://gracedb.ligo.org/gracedb/api"
GIT_TAG = 'gracedb-1.18.dev1-1' GIT_TAG = 'gracedb-1.18-1'
DEFAULT_COLUMNS = "graceid,labels,group,pipeline,search,far,gpstime,created,dataurl" DEFAULT_COLUMNS = "graceid,labels,group,pipeline,search,far,gpstime,created,dataurl"
......
...@@ -280,7 +280,7 @@ class TestGracedb(unittest.TestCase): ...@@ -280,7 +280,7 @@ class TestGracedb(unittest.TestCase):
def test_gittag(self): def test_gittag(self):
# try to make sure GIT_TAG is set properly. # try to make sure GIT_TAG is set properly.
import errno import errno
version = "1.18.dev1" version = "1.18"
try: try:
# If we are in the source dir (setup.py is available) # If we are in the source dir (setup.py is available)
# make sure the version above agrees. # make sure the version above agrees.
......
...@@ -3,7 +3,7 @@ import os ...@@ -3,7 +3,7 @@ import os
from distutils.core import setup from distutils.core import setup
version = "1.18.dev1" version = "1.18"
setup( setup(
name = "ligo-gracedb", name = "ligo-gracedb",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment