There will be maintenance performed on git.ligo.org, chat.ligo.org, containers.lig.org, and docs.ligo.org starting at 9am PDT on Tuesday 18th August 2020. There will be an extremely small period of downtime at the start of the maintenance window as various services are restarted. Please address any comments, questions, or concerns to computing-help@igwn.org.

Commit a7afaf90 authored by Brian Moe's avatar Brian Moe

Changed json package to one available at the sites.

parent 6d1cb11e
ligo-gracedb (1.3-1) unstable; urgency=low
* Replaced simplejson with cjson.
* simplejson not available everywhere in the LSC.
-- Brian Moe <brian.moe@ligo.org> Thu, 14 Jun 2012 11:40:06 -0600
ligo-gracedb (1.2-1) unstable; urgency=low
* Added file download command.
......
......@@ -8,7 +8,7 @@ XS-Python-Version: all
Package: python-ligo-gracedb
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-m2crypto
Depends: ${misc:Depends}, ${python:Depends}, python-m2crypto, python-cjson
XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Description: Gravity Wave Candidate Event Database
......
......@@ -22,11 +22,11 @@ __all__ = ["utils"]
import httplib, mimetypes, urllib
import socket
import os, sys, shutil
import simplejson
import cjson
DEFAULT_SERVICE_URL = "https://gracedb.ligo.org/gracedb/cli"
GIT_TAG = 'gracedb-1.2-1'
GIT_TAG = 'gracedb-1.3-1'
#-----------------------------------------------------------------
# Util routines
......@@ -526,7 +526,7 @@ Longer strings will be truncated.""" % {
# get/print listing.
response = client.listfiles(graceid)
if response and response.status == 200:
for fname in simplejson.loads(response.read()):
for fname in cjson.decode(response.read()):
print(fname)
exit(0)
print(response.reason)
......
[bdist_rpm]
requires = ligo-common m2crypto
requires = ligo-common m2crypto python-cjson
release = 1
......@@ -3,7 +3,7 @@ import os
from distutils.core import setup
version = "1.2"
version = "1.3"
setup(
name = "ligo-gracedb",
......@@ -18,7 +18,7 @@ setup(
provides = ['ligo.gracedb'],
packages = [ 'ligo.gracedb'],
requires = ['ligo', 'M2Crypto'],
requires = ['ligo', 'M2Crypto', 'cjson'],
scripts = [
os.path.join('bin','gracedb'),
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment