Commit e1b9ae94 authored by Branson Stephens's avatar Branson Stephens

Packaging changes for v 1.20.

parent 40b2569c
ligo-gracedb (1.20-1) unstable; urgency=low
* Improved error handling for expired or missing credentials
* Improved error handling when server returns non-JSON response
* Added --use-basic-auth option to command-line client
-- Branson Stephens <branson.stephens@ligo.org> Thu, 11 Feb 2016 15:00:00 -0600
ligo-gracedb (1.19.1-1) unstable; urgency=low
* Force TLSv1 for Python versions less than 2.7.9
* Changed adjustResponse to put retry-after in the JSON response for 429s
......
%define name ligo-gracedb
%define version 1.19.1
%define unmangled_version 1.19.1
%define release 2
%define version 1.20
%define unmangled_version 1.20
%define release 1
Summary: Gravity Wave Candidate Event Database
Name: %{name}
......
......@@ -18,7 +18,7 @@
__all__ = ["cli", "rest"]
GIT_TAG = 'gracedb-1.19.1-1'
GIT_TAG = 'gracedb-1.20-1'
# issue 717. Required for backward compatibility -- make sure "from ligo import gracedb"
# works as it used to.
......
......@@ -25,7 +25,7 @@ DEFAULT_SERVICE_URL = "https://gracedb.ligo.org/gracedb/api"
DEFAULT_BASIC_URL = "https://gracedb.ligo.org/apibasic/"
GIT_TAG = 'gracedb-1.19.1-1'
GIT_TAG = 'gracedb-1.20-1'
DEFAULT_COLUMNS = "graceid,labels,group,pipeline,search,far,gpstime,created,dataurl"
......
......@@ -316,7 +316,7 @@ class TestGracedb(unittest.TestCase):
def test_gittag(self):
# try to make sure GIT_TAG is set properly.
import errno
version = "1.19.1"
version = "1.20"
try:
# If we are in the source dir (setup.py is available)
# make sure the version above agrees.
......
......@@ -20,7 +20,7 @@ import os
from setuptools import setup
version = "1.19.1"
version = "1.20"
setup(
name = "ligo-gracedb",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment