Commit d209c3f2 authored by Moritz Huebner's avatar Moritz Huebner Committed by Colm Talbot
Browse files

Resolve "Introduce a dependency manager"

parent 52aa3a58
......@@ -18,12 +18,13 @@ python-2:
stage: test
image: continuumio/anaconda
before_script:
- apt-get update
- apt-get update -y
- apt-get install gcc -y
- apt install -y libgl1-mesa-glx
- pip install -r requirements.txt
- pip install -r optional_requirements.txt
- pip install pip --upgrade
- pip install pipenv
- pip install enum
- pipenv install --two --python=/opt/conda/bin/python2 --system --deploy
script:
- python setup.py install
# Run tests without finding coverage
......@@ -34,15 +35,16 @@ python-3:
stage: test
image: continuumio/anaconda3
before_script:
- apt-get update
- apt-get update -y
- apt-get install gcc -y
- apt install -y libgl1-mesa-glx
- pip install -r requirements.txt
- pip install -r optional_requirements.txt
- pip install pip --upgrade
- pip install 'coverage>=4.5'
- pip install coverage-badge
- pip install flake8
- pip install pytest-cov
- pip install pipenv
- pipenv install --three --python=/opt/conda/bin/python --system --deploy
script:
- python setup.py install
......
......@@ -18,6 +18,7 @@ Changes currently on master, but not under a tag.
- Adds custom titles to corner plots
- Adds plotting of the prior on 1D marginal distributions of corner plots
- Adds a method to plot time-domain GW data
- Added pipenv as a dependency manager
- Hyperparameter estimation now enables the user to provide the single event evidences
- Add nested samples to nestle output
- Prior and child classes now implement the \_\_eq\_\_ magic method for comparisons
......
[[source]]
url = "https://pypi.org/simple"
verify_ssl = true
name = "pypi"
[packages]
future = "*"
corner = "*"
numpy = ">=1.9"
matplotlib = "<3"
scipy = ">=0.16"
pandas = "*"
deepdish = "*"
mock = "*"
astropy = "<3"
gwpy = "*"
theano = "*"
lalsuite = "*"
# cpnest = "*"
dynesty = "*"
emcee = "*"
nestle = "*"
ptemcee = "*"
pymc3 = "*"
pymultinest = "*"
[requires]
[dev-packages]
[pipenv]
allow_prereleases = false
This diff is collapsed.
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment