Require SWIG version >= 3.0.10, and NumPy version >= 1.7
Currently the official minimum required SWIG and NumPy versions are 2.0.12 and 1.3 respectively, although there are several exceptions, e.g. Python 3 needs SWIG 3.0.9 or later. Bumping the version numbers allows removal of most work-arounds for older SWIG and NumPy versions, thereby cleaning up the SWIG code. The one remaining workaround is in
lal/swig/SWIGTestLALPython.py which still needs SWIG >= 3.0.11 to test pickling of LAL types.
SWIG 3.0.10 was released in 2016, and NumPy 1.7 in 2013, so these version requirements should still be minimal enough not to affect anyone. SWIG 3.0.12 is available on all the LSC clusters (that I could log in to), but the CI still uses Debian stretch images which only have 3.0.10. If/when Debian stretch is no longer supported, the minimum SWIG version could be bumped to 3.0.12 (released in 2017) to remove the last current workaround.
MIN_NUMPY_VERSION now propagate the SWIG and NumPy versions required to the packaging configuration files (where possible), which should make it easier in future to bump the minimum version.
API Changes and Justification
Backwards Compatible Changes
- This change introduces no API changes
- This change adds new API calls
Backwards Incompatible Changes
- This change modifies an existing API
- This change removes an existing API
If any of the Backwards Incompatible check boxes are ticked please provide a justification why this change is necessary and why it needs to be done in a backwards incompatible way.