Commit dab53f3b authored by Kevin Kuns's avatar Kevin Kuns

fix setuptools_scm LookupError bug

If setuptools_scm is installed but gwinc is not called from the gwinc directory, a LookupError was previously thrown. Now the version is set to '?.?.?' in this case.
Apply 1 suggestion(s) to 1 file(s)
clean up patch
parent 05370968
Pipeline #180822 passed with stages
in 2 minutes and 12 seconds
......@@ -13,7 +13,7 @@ except ModuleNotFoundError:
__version__ = setuptools_scm.get_version(fallback_version='?.?.?')
# FIXME: fallback_version is not available in the buster version
# (3.2.0-1)
except (ModuleNotFoundError, TypeError):
except (ModuleNotFoundError, TypeError, LookupError):
__version__ = '?.?.?'
from .ifo import IFOS
from .struct import Struct
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment