Commit d09ca323 authored by Patrick Godwin's avatar Patrick Godwin

update icc, gcc Makefiles with new versions, formatting

parent d2f24c8b
Pipeline #80892 failed with stages
in 0 seconds
......@@ -25,11 +25,11 @@ LOGS_DIR:=logs
PATCH_DIR:=${PWD}/patches
INSTALL_DIR:=${DEPS_PATH}
ifeq ($(findstring debian,$(shell cat /etc/os-release | grep ID=)),debian)
PYTHON_LIB_DIR:=/usr/lib/python2.7/config-x86_64-linux-gnu
PYTHON_DIR:=${DEPS_PATH}/lib/python2.7/site-packages
PYTHON_LIB_DIR:=/usr/lib/python2.7/config-x86_64-linux-gnu
PYTHON_DIR:=${DEPS_PATH}/lib/python2.7/site-packages
else
PYTHON_LIB_DIR:=/usr/lib64
PYTHON_DIR:=${DEPS_PATH}/lib64/python2.7/site-packages
PYTHON_LIB_DIR:=/usr/lib64
PYTHON_DIR:=${DEPS_PATH}/lib64/python2.7/site-packages
endif
# Set package release versions
......@@ -40,9 +40,9 @@ SWIG=swig-3.0.7
METAIO=metaio-8.5.1
LIBFRAME=libframe-8.30
GSTPYTHON=gst-python-1.14.3
GSTPLUGINSGOOD=gst-plugins-good-1.14.3
GSTPLUGINSBASE=gst-plugins-base-1.14.3
GSTREAMER=gstreamer-1.14.3
GSTPLUGINSGOOD=gst-plugins-good-1.14.5
GSTPLUGINSBASE=gst-plugins-base-1.14.5
GSTREAMER=gstreamer-1.14.5
GSL=gsl-1.16
ORC=orc-0.4.26
FFTW=fftw-3.3.8
......
......@@ -49,23 +49,23 @@ LIGOSCALD_GIT_BRANCH="master"
LALSUITE_GIT_BRANCH="master"
# Set package release versions
GSTLALINSPIRAL=gstlal-inspiral-1.6.5
GSTLALCALIBRATION=gstlal-calibration-1.2.10
GSTLALINSPIRAL=gstlal-inspiral-1.6.8
GSTLALCALIBRATION=gstlal-calibration-1.2.11
GSTLALBURST=gstlal-burst-0.1.1
GSTLALUGLY=gstlal-ugly-1.6.4
GSTLALUGLY=gstlal-ugly-1.6.5
GSTLAL=gstlal-1.5.0
LIGOSCALD=ligo-scald-0.5.0
LIGOSCALD=ligo-scald-0.7.0
KAFKA_PYTHON=0.11.5
LIBRDKAFKA=0.11.5
LALAPPS=lalapps-6.24.0
LALINFERENCE=lalinference-1.11.0
LALINFERENCE=lalinference-1.11.3
LALPULSAR=lalpulsar-1.18.0
LALINSPIRAL=lalinspiral-1.9.0
LALBURST=lalburst-1.5.2
LALSIMULATION=lalsimulation-1.9.0
LALSIMULATION=lalsimulation-1.9.1
LALMETAIO=lalmetaio-1.5.1
LALFRAME=lalframe-1.4.5
LAL=lal-6.20.1
LAL=lal-6.20.2
# Specify target/dependency files
GSTINSPIRAL_TARGET=$(INSTALL_DIR)/lib/libgstlalinspiral.so
......
......@@ -29,11 +29,11 @@ LOGS_DIR:=${PWD}/logs
PATCH_DIR:=${PWD}/patches
INSTALL_DIR:=${LAL_PATH}
ifeq ($(findstring debian,$(shell cat /etc/os-release | grep ID=)),debian)
PYTHON_LIB_DIR:=/usr/lib/python2.7/config-x86_64-linux-gnu
PYTHON_DIR:=${LAL_PATH}/lib/python2.7/site-packages
PYTHON_LIB_DIR:=/usr/lib/python2.7/config-x86_64-linux-gnu
PYTHON_DIR:=${LAL_PATH}/lib/python2.7/site-packages
else
PYTHON_LIB_DIR:=/usr/lib64
PYTHON_DIR:=${LAL_PATH}/lib64/python2.7/site-packages
PYTHON_LIB_DIR:=/usr/lib64
PYTHON_DIR:=${LAL_PATH}/lib64/python2.7/site-packages
endif
GSTLAL_REPO:=${PWD}/git/gstlal
......@@ -54,23 +54,23 @@ LIGOSCALD_GIT_BRANCH="master"
LALSUITE_GIT_BRANCH="master"
# Set package release versions
GSTLALINSPIRAL=gstlal-inspiral-1.6.5
GSTLALCALIBRATION=gstlal-calibration-1.2.10
GSTLALINSPIRAL=gstlal-inspiral-1.6.8
GSTLALCALIBRATION=gstlal-calibration-1.2.11
GSTLALBURST=gstlal-burst-0.1.1
GSTLALUGLY=gstlal-ugly-1.6.4
GSTLALUGLY=gstlal-ugly-1.6.5
GSTLAL=gstlal-1.5.0
LIGOSCALD=ligo-scald-0.5.0
LIGOSCALD=ligo-scald-0.7.0
KAFKA_PYTHON=0.11.5
LIBRDKAFKA=0.11.5
LALAPPS=lalapps-6.24.0
LALINFERENCE=lalinference-1.11.0
LALINFERENCE=lalinference-1.11.3
LALPULSAR=lalpulsar-1.18.0
LALINSPIRAL=lalinspiral-1.9.0
LALBURST=lalburst-1.5.2
LALSIMULATION=lalsimulation-1.9.0
LALSIMULATION=lalsimulation-1.9.1
LALMETAIO=lalmetaio-1.5.1
LALFRAME=lalframe-1.4.5
LAL=lal-6.20.1
LAL=lal-6.20.2
GDS=gds-2.18.17
LDASTOOLSFRAMECPP=ldas-tools-framecpp-2.6.5
LDASTOOLSAL=ldas-tools-al-2.6.2
......@@ -78,9 +78,9 @@ SWIG=swig-3.0.7
METAIO=metaio-8.5.1
LIBFRAME=libframe-8.30
GSTPYTHON=gst-python-1.14.3
GSTPLUGINSGOOD=gst-plugins-good-1.14.3
GSTPLUGINSBASE=gst-plugins-base-1.14.3
GSTREAMER=gstreamer-1.14.3
GSTPLUGINSGOOD=gst-plugins-good-1.14.5
GSTPLUGINSBASE=gst-plugins-base-1.14.5
GSTREAMER=gstreamer-1.14.5
GSL=gsl-1.16
ORC=orc-0.4.26
FFTW=fftw-3.3.8
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment