Commit dc0ec84e authored by Patrick Godwin's avatar Patrick Godwin
Browse files

gstlal, gstlal-ugly, gstlal-burst, gstlal-inspiral: remove glue as dependency

parent b5dcf4d9
Pipeline #201089 failed with stages
in 3 minutes and 4 seconds
......@@ -249,12 +249,10 @@ AC_SUBST([LAL_LIBS])
#
# Check for glue, et al.
# Check for LIGO libraries
#
AC_SUBST([MIN_GLUE_VERSION], [2.0.0])
AX_PYTHON_GLUE([$MIN_GLUE_VERSION])
AC_SUBST([MIN_LIGO_SEGMENTS_VERSION], [1.2.0])
AX_PYTHON_LIGO_SEGMENTS([$MIN_LIGO_SEGMENTS_VERSION])
AC_SUBST([MIN_LIGO_LW_VERSION], [1.7.0])
......
......@@ -11,7 +11,6 @@ Build-Depends:
liblal-dev (>= @MIN_LAL_VERSION@),
liblalburst-dev (>= @MIN_LALBURST_VERSION@),
liblalmetaio-dev (>= @MIN_LALMETAIO_VERSION@),
python3-glue (>= @MIN_GLUE_VERSION@),
fakeroot,
pkg-config (>= @MIN_PKG_CONFIG_VERSION@),
gstlal-dev (>= @MIN_GSTLAL_VERSION@),
......@@ -21,7 +20,6 @@ Package: gstlal-burst
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, ${python3:Depends},
python3 (>= @MIN_PYTHON_VERSION@),
python3-glue (>= @MIN_GLUE_VERSION@),
python3-ligo-segments (>= @MIN_LIGO_SEGMENTS_VERSION@),
python3-ligo-scald (>= @MIN_LIGO_SCALD_VERSION@),
python3-gi,
......
......@@ -10,7 +10,6 @@ Group: LSC Software/Data Analysis
# --- package requirements --- #
Requires: fftw >= 3
Requires: python%{python3_pkgversion}-glue >= @MIN_GLUE_VERSION@
Requires: gobject-introspection >= @MIN_GOBJECT_INTROSPECTION_VERSION@
Requires: gstlal >= @MIN_GSTLAL_VERSION@
Requires: gstlal-ugly >= @MIN_GSTLAL_UGLY_VERSION@
......
......@@ -260,12 +260,10 @@ AX_PYTHON_MODULE([lal], fatal)
#
# Check for glue, et al.
# Check for LIGO libraries
#
AC_SUBST([MIN_GLUE_VERSION], [2.0.0])
AX_PYTHON_GLUE([$MIN_GLUE_VERSION])
AC_SUBST([MIN_LIGO_SEGMENTS_VERSION], [1.2.0])
AX_PYTHON_LIGO_SEGMENTS([$MIN_LIGO_SEGMENTS_VERSION])
AC_SUBST([MIN_LIGO_LW_VERSION], [1.7.0])
......
......@@ -23,7 +23,6 @@ Build-Depends:
libgstreamer-plugins-base1.0-dev (>= @MIN_GSTREAMER_VERSION@),
pkg-config (>= @MIN_PKG_CONFIG_VERSION@),
python3-all-dev (>= @MIN_PYTHON_VERSION@),
python3-glue (>= @MIN_GLUE_VERSION@),
python3-gi, python-gi-dev,
python3-lal (>= @MIN_LAL_VERSION@),
python3-lalinspiral (>= @MIN_LALINSPIRAL_VERSION@)
......@@ -42,7 +41,6 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, ${python3:Depends},
libgstreamer-plugins-base1.0-0 (>= @MIN_GSTREAMER_VERSION@),
python3 (>= @MIN_PYTHON_VERSION@),
python3-gi,
python3-glue (>= @MIN_GLUE_VERSION@),
python3-gst-1.0,
python3-h5py,
python3-lal (>= @MIN_LAL_VERSION@),
......@@ -76,7 +74,6 @@ Depends: ${shlibs:Depends}, ${misc:Depends},
libgstreamer1.0-dev (>= @MIN_GSTREAMER_VERSION@),
libgstreamer-plugins-base1.0-0 (>= @MIN_GSTREAMER_VERSION@),
python3-all-dev (>= @MIN_PYTHON_VERSION@),
python3-glue (>= @MIN_GLUE_VERSION@),
python3-gi, python-gi-dev
Description: Files and documentation needed for compiling gstlal-inspiral based plugins and programs.
This package contains the files needed for building gstlal-inspiral based
......
......@@ -11,7 +11,6 @@ Group: LSC Software/Data Analysis
# --- package requirements --- #
Requires: gstlal >= @MIN_GSTLAL_VERSION@
Requires: gstlal-ugly >= @MIN_GSTLALUGLY_VERSION@
Requires: glue >= @MIN_GLUE_VERSION@
Requires: gobject-introspection >= @MIN_GOBJECT_INTROSPECTION_VERSION@
Requires: %{gstreamername} >= @MIN_GSTREAMER_VERSION@
Requires: %{gstreamername}-plugins-base >= @MIN_GSTREAMER_VERSION@
......
......@@ -414,12 +414,10 @@ AX_PYTHON_MODULE([lal], fatal)
#
# Check for glue, et al.
# Check for LIGO libraries
#
AC_SUBST([MIN_GLUE_VERSION], [2.0.0])
AX_PYTHON_GLUE([$MIN_GLUE_VERSION])
AC_SUBST([MIN_LIGO_SEGMENTS_VERSION], [1.2.0])
AX_PYTHON_LIGO_SEGMENTS([$MIN_LIGO_SEGMENTS_VERSION])
AC_SUBST([MIN_LIGO_LW_VERSION], [1.7.0])
......
......@@ -28,7 +28,6 @@ Build-Depends:
liborc-0.4-dev (>= 1:@MIN_ORC_VERSION@),
pkg-config (>= @MIN_PKG_CONFIG_VERSION@),
python3-all-dev (>= @MIN_PYTHON_VERSION@),
python3-glue (>= @MIN_GLUE_VERSION@),
python3-numpy (>= @MIN_NUMPY_VERSION@)
Package: gstlal-ugly
......@@ -51,7 +50,6 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
liborc-0.4-0 (>= 1:@MIN_ORC_VERSION@),
python3 (>= @MIN_PYTHON_VERSION@),
python3-gi,
python3-glue (>= @MIN_GLUE_VERSION@),
python3-gst-1.0,
python3-h5py,
python3-ligo-lw (>= @MIN_LIGO_LW_VERSION@),
......
......@@ -33,7 +33,6 @@ Requires: ldas-tools-framecpp >= @MIN_FRAMECPP_VERSION@
Requires: gds-lsmp >= @MIN_GDS_VERSION@
Requires: gds-framexmit >= @MIN_GDS_VERSION@
Requires: nds2-client >= @MIN_NDS_VERSION@
Requires: python%{python3_pkgversion}-glue >= @MIN_GLUE_VERSION@
Requires: python%{python3_pkgversion}-ligo-lw >= @MIN_LIGO_LW_VERSION@
Requires: python%{python3_pkgversion}-ligo-segments >= @MIN_LIGO_SEGMENTS_VERSION@
Requires: python%{python3_pkgversion}-ligo-scald >= @MIN_LIGO_SCALD_VERSION@
......
......@@ -321,12 +321,10 @@ AX_PYTHON_SYMBOL([lal], [LIGOTimeGPS])
#
# Check for glue, et al.
# Check for LIGO libraries
#
AC_SUBST([MIN_GLUE_VERSION], [2.0.0])
AX_PYTHON_GLUE([$MIN_GLUE_VERSION])
AC_SUBST([MIN_LIGO_SEGMENTS_VERSION], [1.2.0])
AX_PYTHON_LIGO_SEGMENTS([$MIN_LIGO_SEGMENTS_VERSION])
AC_SUBST([MIN_LIGO_LW_VERSION], [1.7.0])
......
......@@ -62,7 +62,6 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
python3 (>= @MIN_PYTHON_VERSION@),
python3-avahi,
python3-gi (>= @MIN_PYGOBJECT_VERSION@),
python3-glue (>= @MIN_GLUE_VERSION@),
python3-gst-1.0,
python3-lal (>= @MIN_LAL_VERSION@),
python3-ligo-lw (>= @MIN_LIGO_LW_VERSION@),
......
......@@ -15,7 +15,6 @@ Requires: python3-avahi
# avahi-ui-tools depreciated in 0.7-19, remove if not necessary
#Requires: avahi-ui-tools
Requires: fftw >= 3
Requires: glue >= @MIN_GLUE_VERSION@
Requires: gobject-introspection >= @MIN_GOBJECT_INTROSPECTION_VERSION@
Requires: gsl
Requires: zlib
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment